Splunk Search

Grouping (Range?) HTTP Status codes

dbcase
Motivator

Hi,

I have queries that I'd like to group HTTP Status codes together... (i.e. anything 200-299, or 300-399, or 400-499, or 500-599) . I have a dropdown that prompts the user to select

 <input type="dropdown" token="http_code" searchWhenChanged="true">
        <label>Select Http Status Code Range:</label>
        <default>200</default>
        <choice value="200">200 - 299</choice>
        <choice value="300">300 - 399</choice>
        <choice value="400">400 - 499</choice>
        <choice value="500">500 - 599</choice>

      </input>

but I'm not sure how to get the query working. This is what I have it it kinda works but it still returns other codes even thought the value is zero

index=itscom source=*access* |rex "HTTP\S+ (?<status>\d+)"|stats count(eval(searchmatch("status=2*"))) as "200-299" by status

alt text

Tags (1)
0 Karma
1 Solution

somesoni2
Revered Legend

Try this

index=itscom source=*access* |rex "HTTP\S+ (?<status>\d+)" 
| bucket status span=100 | eval status=mvindex(split(status,"-"),0)."-".(tonumber(mvindex(split(status,"-"),1))-1)
| stats count by status

View solution in original post

somesoni2
Revered Legend

Try this

index=itscom source=*access* |rex "HTTP\S+ (?<status>\d+)" 
| bucket status span=100 | eval status=mvindex(split(status,"-"),0)."-".(tonumber(mvindex(split(status,"-"),1))-1)
| stats count by status

dbcase
Motivator

Wow, tat is pretty good! It doesn't seem to get the 500-599 ones though.

0 Karma

dbcase
Motivator

nevermind, my fat fingers can't type so well 🙂

0 Karma

somesoni2
Revered Legend

Lets try this than

index=itscom source=*access* |rex "HTTP\S+ (?\d+)" 
 | bucket status span=100 | eval status=mvindex(split(status,"-"),0)."-".(tonumber(mvindex(split(status,"-"),0))+99)
 | stats count by status
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...