Splunk Search

Get App Name/Folder Name using Search

askkawalkar
Path Finder

Hi All, 

I am stuck at a scenario where if user using search in a specific app, then that app folders name should be shown as a filed. 

Is there any way to get current app name using REST or METADATA or any other command ?

Thanks. 

 

Labels (3)
Tags (1)
0 Karma
1 Solution

thambisetty
SplunkTrust
SplunkTrust
index=_internal
| stats count
| appendcols
[| rest /services/search/jobs splunk_server=local
| addinfo
| where sid = info_sid
| rename eai:acl.app as app_name
| fields + app_name]

upvote if this resolves your issue.

————————————
If this helps, give a like below.

View solution in original post

thambisetty
SplunkTrust
SplunkTrust
index=_internal
| stats count
| appendcols
[| rest /services/search/jobs splunk_server=local
| addinfo
| where sid = info_sid
| rename eai:acl.app as app_name
| fields + app_name]

upvote if this resolves your issue.

————————————
If this helps, give a like below.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...