Splunk Search

Filtering fields using a common field in two different sourcetypes

infotork
Explorer

fields in sourcetype1 --> A,B,C, txid ( always has a value)

fields in sourcetype2--> D,E,F, txid ( may occur value for some sources or may not)

Its clear that i have a common field ( txid) in two different sourcetypes  sourcetype1 and sourcetype2

Requirement:

I need to print  A,B from sourcetype1, in case i didnt find "txid" in  sourcetype2,  

Please help

Labels (5)
0 Karma

bowesmana
SplunkTrust
SplunkTrust

How about

sourcetype=sourcetype1 OR sourcetype=sourcetype2
| stats values(A) as A values(B) as B values(sourcetype) as types by txid
| where mvcount(types)==1 AND isnull(mvfind(types,"sourcetype2"))
| table A B txid

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...