Splunk Search

Error "Command failed (ret=1), exiting" in Web.conf

Communicator

Hello Everyone,

http://docs.splunk.com/Documentation/Splunk/6.2.1/Security/Getthird-partycertificatesforSplunkWeb

I have followed above link to created SSL certificate. but when i executed splunk restart command got following error.

Starting splunkweb...  Generating certs for splunkweb server
Loading 'screen' into random state - done
Generating a 1024 bit RSA private key
...++++++
.......................++++++
writing new private key to 'privKeySecure.pem'
-----
Loading 'screen' into random state - done
Signature ok
subject=/CN=USADC-VSSPLDV01/O=SplunkUser
D:\Program Files\Splunk\D:/Program files/Splunk/etc/auth/splunkweb/Splunkcert.pem: Invalid argument
Command failed (ret=1), exiting.

my web.conf file contain

[settings]
enableSplunkWebSSL = true
privKeyPath= etc/\auth/\splunkweb/\mySplunkWebPrivateKey.key
caCertPath= etc/\auth/\splunkweb/\Splunkcert.pem

Please help me on this.

Thanks in advance

0 Karma

SplunkTrust
SplunkTrust

The path listed as invalid looks like a mess with slashes and backslashes muddled together. Do try using Windows-style paths for your certificate files.

0 Karma

SplunkTrust
SplunkTrust

Check what's going wrong in your browser. Connection refused, host unknown, timeout, wrong protocol, ...?
Also check for anything suspicious in Splunk's logs.

0 Karma

Communicator

Hello @Martin Müller

Thanks for your reply.

i changed my web.conf file as below

 [settings]
enableSplunkWebSSL = true
privKeyPath= etc\auth\splunkweb\mySplunkWebPrivateKey.key
caCertPath= etc\auth\splunkweb\Splunkcert.pem

Running splunk restart command i got at end

The Splunk web interface is at https://myhost.com:8000

but when i requesting through URL its not coming. Can you please guide me where going wrong

Thanks

0 Karma