Splunk Search

Display EventCount for specific index.

shinde0509
Explorer

Want to count all events from specific indexes say abc, pqr and xyz only for span of 1h using tstats
and present it in timechart.

Tried this but now working 

| tstats count WHERE earliest=-1d@-3h latest=now index=ABC,PQR,XYZ by index, _time span=1h | timechart sum(count) as count by index.

Labels (3)
0 Karma
1 Solution

thambisetty
SplunkTrust
SplunkTrust

@shinde0509 

| tstats count where index IN (windows,nix)  by _time, span=1h , index
| chart values(count) as count over _time by index
————————————
If this helps, give a like below.

View solution in original post

isoutamo
SplunkTrust
SplunkTrust

Hi

You can try this:

 

| tstats count WHERE earliest=-1d@-3h latest=now index IN (ABC,PQR,XYZ) by index _time span=1h prestats=t 
| timechart span=1h count as count by index.

 

You must use count on both and also span must be the same.

r. Ismo 

shinde0509
Explorer

NO, Getting graph only for first index.

0 Karma

isoutamo
SplunkTrust
SplunkTrust

Sorry, I just copied that from your example. It must be index IN (ABC, PQR,XYZ) or in the old way index = ABC OR index = PQR OR index = XYZ. Fixed into my previous reply.

0 Karma

thambisetty
SplunkTrust
SplunkTrust

@shinde0509 

| tstats count where index IN (windows,nix)  by _time, span=1h , index
| chart values(count) as count over _time by index
————————————
If this helps, give a like below.

shinde0509
Explorer

Thanks, Working.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...