Splunk Search

Datamodel acceleration date range forced to last month

joshiro
Engager

Hi, i need help with some datamodel acceleration issues in CIM.

The problem is that i accelerated a datamodel with 1y summary range, but after rebuilding it, i cant get results older than last month, neither in pivot or tstats from datamodel. The command datamodel works fine with older events.

Tried to tweak the advanced configuration in the datamodel acceleration settings, but nothing changed.

The query using tstats:

 

 

 

 

| tstats prestats=true local=false summariesonly=true allow_old_summaries=true count from datamodel=Network_Traffic.All_Traffic by _time,All_Traffic.transport span=10m
| timechart minspan=10m count by All_Traffic.transport

 

 

 

 


Am i missing some configuration that forces the acceleration date range to the last month range?
Appreciate any insight about this issue.

EDIT: this are the configuration settings

allow_old_summaries = true
allow_skew = 0
backfill_time = -1y
cron_schedule = 1-56/5 * * * *
earliest_time = -1y
hunk.compression_codec = -
hunk.dfs_block_size = 0
hunk.file_format = -
manual_rebuilds = false
max_concurrent = 9
max_time = 3600
poll_buckets_until_maxtime = true
schedule_priority = highest
workload_pool = -
Labels (2)
0 Karma

scelikok
Champion

Hi @joshiro,

Please check backfill range value. It may be 1 month long. That is why older data may not be accelerated.

If this reply helps you an upvote is appreciated.

joshiro
Engager

Changed backfill range to 1y, but it didnt solve the problem.
Thanks for the suggestion.

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!