Splunk SOAR (f.k.a. Phantom)

Wheel installation broken?

hariomenkel
Explorer

I'm currently building an app with Splunk SOAR and somehow the upload functionality for wheel files seems to be broken. I tested with Chrome, Firefox and Internet Explorer all with the same result:

hariomenkel_0-1661411261857.png

As you can see, there is no "Upload" button or any field to drop the wheel file. My Splunk SOAR version is:

5.2.1.78411

Labels (1)
Tags (3)
0 Karma

macgyver
New Member

I ran in the same issue and i'm writing a reply for others that might need the fix, this is a known bug, the upload button is there but it's hidden by some broken css style. Inspect the html code of the dialogbox(where you don't see the upload button) search for "Upload your wheel file here. Only .whl files allowed." there is an input and a div above this text with "style="display: none;"" remove it in both casses and your upload button will appear. You could also run this bit of js in your console:

 

document.querySelectorAll("[style*='display: none']").forEach((elem) => {
    elem.style.display = "block"
})

 

Hope this will help others out too, cheers
Tags (1)
0 Karma
Get Updates on the Splunk Community!

Introducing the 2024 SplunkTrust!

Hello, Splunk Community! We are beyond thrilled to announce our newest group of SplunkTrust members!  The ...

Introducing the 2024 Splunk MVPs!

We are excited to announce the 2024 cohort of the Splunk MVP program. Splunk MVPs are passionate members of ...

Splunk Custom Visualizations App End of Life

The Splunk Custom Visualizations apps End of Life for SimpleXML will reach end of support on Dec 21, 2024, ...