Splunk IT Service Intelligence

how to solve this error in Splunk-TA-nix


message from "/opt/splunk/etc/apps/Splunk_TA_nix/bin/vmstat.sh" dmesg: read kernel buffer failed: Operation not permitted

Labels (1)
0 Karma


From splunk_TA_Nix app few sourcetpye are missing like -sourcetype protocol is not excute in bin command sh protocol.sh  no data is showing .can you please let me what is the reason of missing sourcetype.

0 Karma

Splunk Employee
Splunk Employee

This may be related to restricting kernel access on instances. You can try running the following command to lift the restrictions on the kernel.

kernel.dmesg_restrict = 0

To make this change persistent, you can save the above parameter in a conf file as below:



cat /etc/sysctl.d/10-local.conf 


If you find the answer helpful, an upvote/karma is appreciated
Get Updates on the Splunk Community!

Observability | How to Think About Instrumentation Overhead (White Paper)

Novice observability practitioners are often overly obsessed with performance. They might approach ...

Cloud Platform | Get Resiliency in the Cloud Event (Register Now!)

IDC Report: Enterprises Gain Higher Efficiency and Resiliency With Migration to Cloud  Today many enterprises ...

The Great Resilience Quest: 10th Leaderboard Update

The tenth leaderboard update (11.23-12.05) for The Great Resilience Quest is out >> As our brave ...