Splunk IT Service Intelligence

how to solve this error in Splunk-TA-nix


message from "/opt/splunk/etc/apps/Splunk_TA_nix/bin/vmstat.sh" dmesg: read kernel buffer failed: Operation not permitted

Labels (1)
0 Karma


From splunk_TA_Nix app few sourcetpye are missing like -sourcetype protocol is not excute in bin command sh protocol.sh  no data is showing .can you please let me what is the reason of missing sourcetype.

0 Karma

Splunk Employee
Splunk Employee

This may be related to restricting kernel access on instances. You can try running the following command to lift the restrictions on the kernel.

kernel.dmesg_restrict = 0

To make this change persistent, you can save the above parameter in a conf file as below:



cat /etc/sysctl.d/10-local.conf 


If you find the answer helpful, an upvote/karma is appreciated
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...