Splunk IT Service Intelligence

Why did I get the following error after installing Splunk App for IT Service Intelligence: "There was an error processing the upload"

chinuakatchy
Explorer

I downloaded the SPl file but I was unable to install it. I got the following response: "There was an error processing the upload. Invalid app contents: archive contains more than one immediate subdirectory: and SA-ITSI-MetricAD"

0 Karma

chinuakatchy
Explorer

Yes I am trying to install it through the GUI. I am running Splunk 7.1.2. and Splunk ITSI version 3.1.4.
Please is there any guide for installing it via the CLI?

0 Karma

kmorris_splunk
Splunk Employee
Splunk Employee

Are you trying to install it through the GUI? ITSI needs to be installed from the command line. It contains several other app directories.

0 Karma

chinuakatchy
Explorer

Yes I am trying to install it through the GUI. Please is there any guide for installing it via the CLI?

0 Karma

kmorris_splunk
Splunk Employee
Splunk Employee

Install ITSI on a single instance
Install ITSI on a single Splunk Enterprise instance. In a single-instance deployment, a single Splunk Enterprise instance serves as both search head and indexer.

You must install ITSI by extracting the ITSI installation package. ITSI does not support installation using the app manager in Splunk Web or using the splunk install app command at the command line.

Log in to splunk.com with your Splunk.com user name and password.
Download the latest Splunk IT Service Intelligence product.
Stop splunk. For example:
cd $SPLUNK_HOME/bin
./splunk stop
Extract the ITSI installation package into $SPLUNK_HOME/etc/apps. For example:
tar -xvf splunk-it-service-intelligence_.spl -C $SPLUNK_HOME/etc/apps
On Windows, rename the file extension from .spl to .tgz first and use a third-party utility like 7-Zip to perform the extraction.

Start splunk. For example:
cd $SPLUNK_HOME/bin
./splunk start

0 Karma

mstjohn_splunk
Splunk Employee
Splunk Employee

Hi @chinuakatchy,

Could you provide us more context on your install? For instance, what version of Splunk are you using, etc. You have a much better chance of getting your question answered if you provide more information about your issue. Plus, it will help guide future community users who are facing a similar problem.

0 Karma

chinuakatchy
Explorer

I am running Splunk 7.1.2. and Splunk ITSI version 3.1.4.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.