Splunk IT Service Intelligence

Unable to save correlation search in ITSI getting error "Invalid search string: This search cannot be parsed when parse_only is set to true."

bangalorep
Communicator

Hello,

Using ITSI on Splunk Cloud.

Using the following search to create a correlation search

search pattern
| eval MatchPattern =
[| inputlookup test.csv
| eval PatternToSearch="\"%".Error."%\""
| eval commandToExecute="message LIKE ".PatternToSearch.",\"".Message."\""
| fields commandToExecute
| stats delim="," values(commandToExecute) as commandToExecute
| mvcombine commandToExecute
| eval commandToExecute="case(".commandToExecute.",1=1,\"UnMatched\")"
| return $commandToExecute]
| fillnull MatchPattern value="Null"
| search MatchPattern!= "UnMatched"

The search runs fine but when I try to save the correlation search, I get the error "Invalid search string: This search cannot be parsed when parse_only is set to true." which I found is a Javascript limitation. Any workaround for this?

0 Karma

esnyder_splunk
Splunk Employee
Splunk Employee

You can't use a sub-search returning into an eval in a correlation search. As a workaround:

1. Create and save a basic correlation search with all of the information you want outside of the search.

2. As an admin user, go to Settings > Searches, reports, and alerts and open the correlation search you just created.

3. Add the sub-search you were trying to add there.

This workaround is also documented in known issue ITSI-3322 in the release notes. 

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!