Splunk IT Service Intelligence
Highlighted

Splunk ITSI - The search specifies a macro 'assess_severity' that cannot be found

Explorer

hi, I'm finding lot of these errors in my ITSI cluster (4.4.1/7.3.3) index=_internal

05-12-2020 12:56:01.520 +0200 ERROR SearchParser - The search specifies a macro 'assess_severity' that cannot be found. Reasons include: the macro name is misspelled, you do not have "read" permission for the macro, or the macro has not been shared with this application. Click Settings, Advanced search, Search Macros to view macro information.

I find 4 macros in the app SA-ITOA, all having 1 to 6 different arguments required. Sharing is Global, everyone have read permissions.

Anyone with an answere or suggestion on what to do?

Labels (2)
0 Karma
Highlighted

Re: Splunk ITSI - The search specifies a macro 'assess_severity' that cannot be found

Explorer

The event are followed by an event like:
05-12-2020 12:56:01.520 +0200 ERROR SHCRepJob - failed job=SHPDelegateSearchJob peer="myhostname.fake.splunk.no", guid="E3E36E38-52DC-4F32-83CD-498681B3A8B3" savedsearch=system;; err=uri=https://172.20.242.50:8089/servicesNS/nobody/itsi/shcluster/member/delegatejob/Indicator%20-%204eb62...dispatch?outputmode=json, error=500 - \n In handler 'shclustermemberdelegatejob': Error in 'SearchParser': The search specifies a macro 'assessseverity' that cannot be found. Reasons include: the macro name is misspelled, you do not have "read" permission for the macro, or the macro has not been shared with this application. Click Settings, Advanced search, Search Macros to view macro information.

0 Karma
Highlighted

Re: Splunk ITSI - The search specifies a macro 'assess_severity' that cannot be found

Explorer

Resolved. It was acctually some old searches defined on our deployer. Removed those and pushed new boundle. case closed 🙂

0 Karma
Highlighted

Re: Splunk ITSI - The search specifies a macro 'assess_severity' that cannot be found

Explorer

It was acctually some old searches defined on our deployer. They had the wrong number of inputs. Removed those and pushed new boundle. case closed 🙂

View solution in original post

0 Karma
Speak Up for Splunk Careers!

We want to better understand the impact Splunk experience and expertise has has on individuals' careers, and help highlight the growing demand for Splunk skills.