Splunk IT Service Intelligence
Highlighted

Splunk IT Service Intelligence: Why am I getting error "URI Too Large" when trying to enable drilldown options from Deep Dive swim lanes?

Path Finder

I'm trying to configure some drilldown options from swim lanes in the Deep Dive view in the Splunk IT Service Intelligence app, but having some difficulties doing that. My goal is to be able to drill down to different dashboards from various lanes.
alt text
When enabling overlay for a KPI's swim lane and selecting that lane, I get an error (see picture). Checking the console, I find the following error message: "Failed to load resource: the server responded with a status of 414 (Request-URI Too Large)". Any ideas on how/where I can fix/set this?

Highlighted

Re: Splunk IT Service Intelligence: Why am I getting error "URI Too Large" when trying to enable drilldown options from Deep Dive swim lanes?

New Member

hey did you able to resolve it, how you reached till custom drill down. i also want to open the custom dashboard from deep dive but not sure how to open that?

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: Why am I getting error "URI Too Large" when trying to enable drilldown options from Deep Dive swim lanes?

Path Finder

I have similar issue https://answers.splunk.com/answers/577476/export-of-results-from-search-screen-results-in-41.html

No result found yet. Have you fixed your issue?

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: Why am I getting error "URI Too Large" when trying to enable drilldown options from Deep Dive swim lanes?

Path Finder

Hi! No fix yet. I haven't been able to work on this since I posted the question. Will update if I figure it out 🙂

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: Why am I getting error "URI Too Large" when trying to enable drilldown options from Deep Dive swim lanes?

Path Finder

After updating to 3.0 the problem seems to have been resolved. No idea what caused the error unfortunately.

For the record, in order to enable drilldown from deep dive you need to create a deepdivedrilldowns.conf in /etc/apps/itsi/local. See /etc/apps/itsi/README/deepdivedrilldowns.conf for options 🙂
When created run http://yoursplunkserver:8000/en-GB/debug/refresh to activate the configuration.

View solution in original post

0 Karma