Splunk IT Service Intelligence
Highlighted

Splunk IT Service Intelligence: When I created a "view only" user in Splunk, why am I unable to access the app?

Explorer

Hi guys,
I created a user in Splunk to "view only". on the left hand side it showing all the apps I have, unfortunately I'm not able to access the Splunk IT Service Intelligence (ITSI) app in Splunk. Plz help with this. when i click on ITSI app, it showing the following error

404 Not Found
Return to Splunk home page
Page not found!
View more information about your request (request ID = 286c7sfelkferldf10) in Search
This page was linked to from https://localhost:8000.

Thank you.

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: When I created a "view only" user in Splunk, why am I unable to access the app?

Splunk Employee
Splunk Employee

To access ITSI, there are specific user roles defined in ITSI. You need to make sure the user you have created has the appropriate roles assigned. (https://docs.splunk.com/Documentation/ITSI/2.4.1/Configure/Configureusersandroles)
itoauser
itoa
analyst
itoa_admin

View solution in original post

Highlighted

Re: Splunk IT Service Intelligence: When I created a "view only" user in Splunk, why am I unable to access the app?

Explorer

Thank you

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: When I created a "view only" user in Splunk, why am I unable to access the app?

Explorer

Once again thank you, now I'm able to get into ITSI app. Here there are like 5 glass tables . Is there any way to display specific glasstable for users who only have view option.

Thanks in advance.

0 Karma
Highlighted

Re: Splunk IT Service Intelligence: When I created a "view only" user in Splunk, why am I unable to access the app?

Splunk Employee
Splunk Employee

You can create your own roles, and edit existing roles. Do you have something more specific you're looking to do? If you mean userA can see only one glass table, than you can create a role that has required functionality and limit that specific role using the permissions for the glass table(s) in question. Take a look at:
https://docs.splunk.com/Documentation/ITSI/2.4.1/Configure/Configureusersandroles

0 Karma