Splunk IT Service Intelligence

ITSI - Is there a setting to have the Service Analyzer Screen refresh

Splunk Employee
Splunk Employee

Hi,
The Service Analyzer screen appears to be static and does not change after initial viewing of the Services and KPI's.
I would like to see the screen refresh every 5 minutes, but I can't seem to find the documentation on how to do this (assuming that my first statement is correct).

So, my questions are:
1) Is there a setting for this?
2) If so, what .conf file and parameter is it?

Thank you.

0 Karma
1 Solution

Motivator

Refer the below documnet:

https://docs.splunk.com/Documentation/ITSI/3.0.1/User/ServiceAnalyzer

Automatically refresh the service analyzer
You can automatically refresh the service analyzer when a relative time range is selected from the time picker (as opposed to real-time). By default, auto-refresh is disabled for service analyzer. To enable it, create itsi_service_analyzer.conf in $SPLUNK_HOME/etc/apps/SA-ITOA/local and add the following stanza to it:

[auto_refresh]
disabled = 0
interval = 180
Interval is in seconds and defines the time interval to automatically refresh service analyzer. This configuration file setting applies to the default service analyzer and all saved service analyzers. For more information about this configuration file, see $SPLUNK_HOME/etc/app/SA-ITOA/README/itsi_service_analyzer.conf.spec.

Auto-refresh is disabled if a real-time selection is made in the time picker.

View solution in original post

Motivator

Refer the below documnet:

https://docs.splunk.com/Documentation/ITSI/3.0.1/User/ServiceAnalyzer

Automatically refresh the service analyzer
You can automatically refresh the service analyzer when a relative time range is selected from the time picker (as opposed to real-time). By default, auto-refresh is disabled for service analyzer. To enable it, create itsi_service_analyzer.conf in $SPLUNK_HOME/etc/apps/SA-ITOA/local and add the following stanza to it:

[auto_refresh]
disabled = 0
interval = 180
Interval is in seconds and defines the time interval to automatically refresh service analyzer. This configuration file setting applies to the default service analyzer and all saved service analyzers. For more information about this configuration file, see $SPLUNK_HOME/etc/app/SA-ITOA/README/itsi_service_analyzer.conf.spec.

Auto-refresh is disabled if a real-time selection is made in the time picker.

View solution in original post

Splunk Employee
Splunk Employee

This is great! I'll put this on my test instance today!

0 Karma

Builder

Hello @sbowser_splunk

I believe it would appear static if the health scores and kpis' values were not changing values

In addition, as per Splunk Doc,

The minimum time range that can be selected in the time picker is 45 minutes. This is the minimum length of time needed to ensure all KPI data is available. If you select Last 15 minutes, or any time range that is less than 45 minutes, the time picker is automatically set to 45 minutes.

Hope it helps!

Thanks!

0 Karma