Splunk Enterprise

loss of time input

Vadim_Peskov
Observer

Hi!
Faced with a very specific problem.
We use splunk enterprise 7.3.0. We have ru_RU written in the address bar instead of en-US. In the file /opt/splunk/etc/system/local/times.conf, we changed the display language of the time input to Russian. When the Date & Time Range item is selected in the time input and the period is set in it by the Between button, the data is applied, but the input itself disappears from the dashboard. An error appears in the console: moment().splunkFormat() does not support the locale ru. If you use en_US instead of ru_RU in the address bar, the error does not occur, but it does not suit us.
I tried adding the file ru.js to the locale folder, then splunk stops working.
Please tell me how you can fix this error. Thanks!

Labels (3)
0 Karma

_JP
Contributor

...That's quite an out of date version that is way out of support.  Also, I'm not sure what your ru.js file is doing, since the typical localization process involves creating the po/mo files within the mrsparkle library localization folders.

The localization stuff in Splunk is based on gettext.  For your version of Splunk these are the localization instructions here and here

Have you tried editing the portable object files for your formatting?

 

 

0 Karma
Get Updates on the Splunk Community!

Accelerate Service Onboarding, Decomposition, Troubleshooting - and more with ITSI’s ...

Accelerate Service Onboarding, Decomposition, Troubleshooting - and more! Faster Time to ValueManaging and ...

New Release | Splunk Enterprise 9.3

Admins and Analyst can benefit from:  Seamlessly route data to your local file system to save on storage ...

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...