Splunk Enterprise

Update from 8.2 to 9.0.4- How to resolve problems kvstore upgrade to wiredtiger?

osakachan
Communicator

Hello Folks,

 

I am having a bit of trouble finishing an update. 

I have this message in the update:

osakachan_0-1678877370878.png

¿Where is the migration log? mongod.log? I do not see anything to work with.

 

Now kvstored is disabled and I can not manually update to wiredTiger.

Thanks in advance.

0 Karma

osakachan
Communicator

Looks like it has nothing to do with wiredTiger at all.

The problem the kvstore does not initiate in 9.0.4. 

This is with --verbose

An error occurred during the last operation ('getParameter', domain: '15', code: '13053'): No suitable servers found: `serverSelectionTimeoutMS` expired: [connection closed calling ismaster on '...<domain>...:8191']

 

in mongd.log we can se a lot of connections and disconects.

 

We tried infinity of things arround TLS certificates without results.

Tags (3)
0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

all logs are on $SPLUNK_HOME/var/log/splunk/ directory.

Which kind of instance you are upgrading to 9.0.4 (Indexer, SH or all in one box)?

This error said that you haven't sslPassword for kvstore. Just check from $SPLUNK_HOME/etc/system/local/server.conf what you have and if/when needed use

splunk btool server list sslConfig --debug

That should show your sslPassword and where it has set.

r. Ismo

0 Karma

osakachan
Communicator

all logs are on $SPLUNK_HOME/var/log/splunk/ directory.

Ah, yes, I saw it now.. but looks like is the same information than you can see as the update is running.

 


Which kind of instance you are upgrading to 9.0.4 (Indexer, SH or all in one box)?


Is master/DS with SH capabilities. Right now is not a problem because of that, but as you can expect, I would liketo understand what is happening for when we update the SH.

Because we encountered this problem, I think disabling kvstore in IDX and HF levels is an option. I understand that disabling it at that nodes is not problem because it only works with "lookup" data. ¿?¿?

 


This error said that you haven't sslPassword for kvstore. Just check from $SPLUNK_HOME/etc/system/local/server.conf what you have and if/when needed use

 

splunk btool server list sslConfig --debug

 

That should show your sslPassword and where it has set.

 


Yeah, I know, but certs are passwordless, so sslPassword is blank. Testing with random password results in this:

osakachan_0-1678881370670.png

And finishing, it is like an instance of mongodb keeps alive and using the default port:

 

osakachan_1-1678881534633.png

 

Trying to do the upgrade to wiredtiger happens this:

osakachan_2-1678882501794.png

 

mongod.log

osakachan_3-1678882526035.png

 

 

Kind regards.

 

0 Karma

osakachan
Communicator

We did not have any kind of problem to update kvstore in HF level. If disabled, SplunkDBConnect stoped working.

0 Karma
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...