Splunk Enterprise

Splunk DB Connect: SQL level 1 ORA-01882: timezone region not found After upgrading to db_connect 3.x (Splunk 7.3.6)

hiteshdholakiya
Explorer

hiteshdholakiya_0-1611865398614.png


After upgrading to Splunk 7.3.6 and DB_connect 3.x, query is throwing the error: "SQL level 1 ORA-01882: timezone region not found"

I have already tried setting up the following option in JRE:

 

 

-Doracle.jdbc.timezoneAsRegion=false

or

-Duser.timezone=GMT

 

 


The connection works perfectly, but when I try to query the data, it shows the region error.


Also I have tried the following jdbc versions:

 

 

$ java -jar ojdbc6.jar -getversion
Oracle 12.1.0.2.0 JDBC 4.0 compiled with JDK6 on Mon_Jun_30_11:28:06_PDT_2014
#Default Connection Properties Resource
#Mon Jan 11 14:28:28 EST 2021


java -jar ojdbc7.jar -getversion
Oracle 12.1.0.1.0 JDBC 4.1 compiled with JDK7 on Thu_Apr_04_15:09:24_PDT_2013
#Default Connection Properties Resource
#Thu Jan 28 15:28:52 EST 2021

$ java -jar ojdbc8.jar -getversion
Oracle 12.2.0.1.0 JDBC 4.2 compiled with javac 1.8.0_91 on Tue_Dec_13_06:08:31_PST_2016
#Default Connection Properties Resource
#Thu Jan 28 15:29:24 EST 2021

 

 



Java Version:

 

 

$ java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

 

 

 

Can anyone please take a look into this?

Any help is greatly appreciated.

Thanks in advance.

Labels (1)
0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!