Splunk Enterprise

KV Store Help needed.

Loves-to-Learn Lots

Can any one help?


I am trying to configure a KV Store lookup, I have followed the online documentation:





However when I try and populate any data into the lookup with an outputlookup command I get:

`Error in 'outputlookup' command:Lookup failed because collection 'asset_enrichment' in app 'search does not exist or user does not have read access.

I have a simple collections.conf


and my transforms.conf


external_type = kvstore

case_sensitive_match = false

collection = asset_enrichment

fields_list = _key, asset_enrichment guid, ........ etc

Both deployed to my SHC. My assumption is that they are only required on the SH and not the index cluster due to the KV store living on the SH?


I have created a Lookup definitition 


But if I look in Settings - Lookups - Lookup table files my look up is not listed at all.


Any suggestions?

Labels (1)
0 Karma


hi @Martin583,

You don't need collection and transforms configurations indexer cluster. And KVStore collection definitions exist in  Settings - Lookups - Lookup definitions, not in Lookup table files.

You need to change the permissions of this KVStore lookup definition to share it with other apps (if it is not part of the search app) and read access to users who wants to search it.


If this reply helps you, a like would be appreciated.

0 Karma

Loves-to-Learn Lots

Sorry I probably wasn't clear.

I can see the definition in lookup defintions.

But I cannot see any listing of the asset_enrichment lookup anywhere.


Also I had already shared the definition globally, when I first saw the error message of the lookup not existing of user had no permission, but it didn't make a difference.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.