Splunk Enterprise

Is this issue with indexfile, or search, or index?

jason0
Path Finder

Hello

I am perplexed: when I run firebrigade, and choose "detail | index detail" and having chosen a host, my index list is incomplete.

I see in the source where it gets input on line 20: "inputlookup fb_hostname_index_cache".

I see the contents of the fb_hostname_index_cache.csv file is the same incomplete list

I found the periodic search where it extracts the data to put into "fb_hostname_index_cache.csv", the search command being:

 index=summary search_name="DB inspection" | dedup orig_host, orig_index | sort orig_host, orig_index | table orig_host,orig_index | outputlookup fb_hostname_index_cache

When I run this search, I get "Error in 'outputlookup' command: The lookup table 'fb_hostname_index_cache' is invalid."

when I run the search without "| outputlookup fb_hostname_index_cache", I get an incomplete list of my indexes.

so a few things might be happening that I don't know how to determine.

  1. splunk doesn't like something about the "fb_hostname_index_cache.csv" file
  2. not all of the indexes are being returned from the query
  3. something isn't right about the contents of "index=summary"

This issue appeared shortly after i upgraded from 8.0.3 to 8.1.6 to 9.0.0.1.

My current system has six dedicated indexers, and an independent search head.  there are also three heavy forwarders.

Can someone shed some light on this?  

Thank you!

 

 

Labels (3)
0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...