Splunk Enterprise
Highlighted

500 server error after upgrade from 6.2.3 to 6.6.1

We have been trying to upgrade splunk light from 6.2.3 to 6.6.1 and get '500 internal server error' right after logging in.

I have looked at all the splunk logs and none seem to give any more details on the error. Is there anywhere I can enable detailed errors to show up through the browser so I can see the actual error message?

Tags (2)
0 Karma
Highlighted

Re: 500 server error after upgrade from 6.2.3 to 6.6.1

Champion

dumb comment...have you cleared you browser cache? I know we ran into some funky browser problems when going from 6.3 to 6.5.

I think the web_service log is where you want to look - may be a bit more information in there. And I'm not sure if that component can log more, but here is the docs for enabling debug logging.

0 Karma
Highlighted

Re: 500 server error after upgrade from 6.2.3 to 6.6.1

Ultra Champion

Similar issue with the 6.4.0 version - 500 Internal Server Error after upgrading to 6.4.0

0 Karma
Highlighted

Re: 500 server error after upgrade from 6.2.3 to 6.6.1

In the end, I did a clean install and copied over data and configs from the old install. This time it worked with no issues. So I still have no idea what the root cause was, but we are good now.

View solution in original post

0 Karma
Highlighted

Re: 500 server error after upgrade from 6.2.3 to 6.6.1

Splunk Employee
Splunk Employee

Hi @wayne.stringfield - Glad you were able to figure out and resolve the issue on your own. Please don't forget to click "Accept" below your answer to resolve your question. Thanks.

0 Karma