Splunk Enterprise Security

In Splunk Enterprise Security, how do you Include empty results in a tstats search?

yemyslf
Path Finder

I am using tstats to search for some IP addresses. I'm trying to return the count of those IP addresses, which is easy enough. I'd also like to have the IP listed in my search results even if no items were found.

Here is an example of my search using fillnull, but it's only showing the IPs that are found.

Any suggestions on how to accomplish this?

  | tstats summariesonly=true  allow_old_summaries=true count from  datamodel=Web where  sourcetype=mysource AND          (Web.src = 192.168.1.2  OR Web.src= 192.168.2.3  OR 192.168.3.4) by Web.src  
| fillnull value="0"  
| rename "Web.*"   as *
0 Karma

woodcock
Esteemed Legend

This is the Sentinel Search problem discussed (with solution) here:

https://conf.splunk.com/session/2015/conf2015-LookupTalk.pdf

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Rounding off the Splunk Dashboard Contest

What does a contest-winning Splunk dashboard look like? In this case, it isn't in a browser tab at all. It ...

A Four Part Event Series: AI + Observability: AI Agents, LLMs, Apps, & Infrastructure

AI + Observability: AI Agents, LLMs, Apps, & Infrastructure The rapid evolution of artificial intelligence ...