Security

"Your session is invalid" message when using CLI

seren
Explorer

I've just upgraded to 4.2 and am having problems with command-line scripts that run splunk searches. When I run a search from the CLI, I'm prompted with:

"Your session is invalid.  Please login."

If I enter my username and password manually, it works for a while but prompts again after a period of time. This is causing my scripts to fail. Any ideas how to disable authentication from the command-line, or some other work-around? Thanks in advance.

0 Karma
1 Solution

LCM
Contributor

You have a timeout (configurable) on the UI, so as the CLI. Anyway - you either could try this one AuthToken or within your command-line script: splunk search '<search> -auth user:password - of course in that option the password is visible to anyone who can read your script, or when you do 'ps -ef'!

View solution in original post

LCM
Contributor

You have a timeout (configurable) on the UI, so as the CLI. Anyway - you either could try this one AuthToken or within your command-line script: splunk search '<search> -auth user:password - of course in that option the password is visible to anyone who can read your script, or when you do 'ps -ef'!

seren
Explorer

Thanks a lot. That was it.

0 Karma
Get Updates on the Splunk Community!

Synthetic Monitoring: Not your Grandma’s Polyester! Tech Talk: DevOps Edition

Register today and join TekStream on Tuesday, February 28 at 11am PT/2pm ET for a demonstration of Splunk ...

Instrumenting Java Websocket Messaging

Instrumenting Java Websocket MessagingThis article is a code-based discussion of passing OpenTelemetry trace ...

Announcing General Availability of Splunk Incident Intelligence!

Digital transformation is real! Across industries, companies big and small are going through rapid digital ...