Security

error code 1

msantoro1
Explorer

What exactly is error code 1? I wrote a search function that seems to work in that it does what I want it to, but it also returns error code 1.

Tags (2)

hemant_asnani
New Member

I am experiencing a similar problem search is returning an error code 1 when using it for the following search: index=euc_spacesdata sourcetype=SpacesActivities | lookup PeopleCentralLookup corpid

I have a field alias for USERNAME field to create the corpid field and am able to search via the corpid alias.

0 Karma

sideview
SplunkTrust
SplunkTrust

I've never seen a python search command return any "error codes" other than 1 so I suspect error code 1 is just the opposite of "success code 0". That said, why the system gives back a nice exception str sometimes, and "error code 1" in other cases, I haven't figured out.

atreece
Path Finder

I am having the same problem, actually. I have a relatively simple search, actually:
index=(withheld for company privacy) [fields] | stats count by task_name | sort -count | rename count AS "Times Completed", task_name AS "Most Completed tasks" | head 20
and it is giving me the following message:
Script for lookup table 'user-name' returned error code 1. Results may be incorrect.

anyone have answers for this?

0 Karma

jedinerd
New Member

Can you post the search that your using? I did a little looking around and the only other instance i could find of error 1 was from a search command that accessed external resources.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...