Security

Why is the Splunk user session timeout is not working?

Path Finder

Hi,

I have set the below in web.conf to set the user timeout session to 20 min but it's not working, any idea where is the issue:

web.conf
[settings]
tools.sessions.timeout = 10
ui_inactivity_timeout = 10

server.conf
[general]
sessionTimeout = 600s
0 Karma

Super Champion

HI @Dev_Choudhary,

If you are using SplunkWeb (splunkweb) to access the Splunk instance (splunkd), the smaller of the two timeout attributes prevails. So, if tools.sessions.timeout in web.conf has a value of "90" (minutes), and sessionTimeout in server.conf has a value of "1h" (1 hour; 60 minutes), the session will timeout after 60 minutes.
refer https://docs.splunk.com/Documentation/Splunk/7.0.2/Admin/Configureusertimeouts

0 Karma

Super Champion

I can see that you have set timeout session to 10 min and not 20 min...does it also not working for 10min?

0 Karma

SplunkTrust
SplunkTrust

Did you restart Splunk after changing the settings?

---
If this reply helps you, an upvote would be appreciated.
0 Karma

Path Finder

yes, by both way 1> from web console and 2> by command

0 Karma
State of Splunk Careers

Access the Splunk Careers Report to see real data that shows how Splunk mastery increases your value and job satisfaction.

Find out what your skills are worth!