Security

Problems with SSO on Windows - can't search

ruiaires
Path Finder

Following this question:
http://splunk-base.splunk.com/answers/4863/setting-up-sso-on-windows

I was able to get SSO working on W2K8/IIS7 with Ionics ISAPI Filter.
Proxy is setup at localhost (port 80) and redirects to the server on 8000 (using the name, not localhost)
Everyhing looks good, SSO debug page shows Remote-User header being received correctly.
Splunk is using LDAP authentication (over Active Directory).
SSO is using permissive mode so allow users to still access splunk at http://server:8000 and login with their existing LDAP username. Role is mapped using the LDAP group mapping and it's working fine.

The problem is, when a user accesses through the proxy, Splunk does not show any data (searches return empty, summary dashboard also empty) as if the user did not have any roles assigned. However, the user can access the Manager and, if it has a admin role, it can do anything there... But all the searches and dashboards do not work...

It appears to be the same problem desccribed in:
http://splunk-base.splunk.com/answers/42223/sso-broken-after-upgrade-to-431

Tags (2)

claudio_manig
Communicator

Hi
We got exactly the same problem - how did you fixed it?

Would appreciate any help- thx

0 Karma
Get Updates on the Splunk Community!

Security Highlights | November 2022 Newsletter

 November 2022 2022 Gartner Magic Quadrant for SIEM: Splunk Named a Leader for the 9th Year in a RowSplunk is ...

Platform Highlights | November 2022 Newsletter

 November 2022 Skill Up on Splunk with our New Builder Tech Talk SeriesCan you build it? Yes you can! *play ...

Splunk Education - Fast Start Program!

Welcome to Splunk Education! Splunk training programs are designed to enable you to get started quickly and ...