Reporting

when my job runs most of the time getting time out, How can is resolve this ?

Communicator

We are getting below errors in splunkd logs:
getting in http client error=Read Timeout, while trying to reach other splunk search-head in cluster.
Due to this getting multiple reports

Tags (2)
0 Karma
1 Solution

Communicator

There were some network issues due to which there were above timeout errors.
In resolve.conf, splunk servers were pointing to old dns servers.
Issue was resolve after we modified it.

View solution in original post

0 Karma

Communicator

There were some network issues due to which there were above timeout errors.
In resolve.conf, splunk servers were pointing to old dns servers.
Issue was resolve after we modified it.

View solution in original post

0 Karma

Influencer

I fixed this on our cluster by increasing the shclustering timeouts in server.conf on our search heads:

[shclustering]
send_timeout = 300
rcv_timeout = 300
rep_cxn_timeout = 25
rep_send_timeout = 25
rep_rcv_timeout = 50

Make sure all of your search heads are up and reachable on the management port (TCP/8089 by default) as well.

0 Karma

Champion

Did you try changing session timeout of splunk ( Settings--------------->General Settings---------------->Session timeout --------->generally default value is 1h------> change it to higher value)

0 Karma

Communicator

don't think so it will work as it is user session timeout value

0 Karma