Reporting

Why is a Splunk embedded report failing in a search head cluster?

miimsplunk
Engager

I am using the embed iframe utility, but I've noticed that it is failing and I don't know if it's related to my search head cluster. We use a VIP for 3 search head clusters. When we embed the html in a report, we've noticed that it's hit or miss if you can view the results. Upon further troubleshooting we've noticed that if we roll through each server using the html embed link (removing the VIP name and putting in the direct IP or Servername) we can eventually see the results on ONE search head. Is that because the embedded iframe is only viewable on the search head where the results were created?
i.e. splunk.companyname.com doesn't always work but if we begin to roll through our VIP names server1:8000 or server2:8000 or server3:8000 we will eventually hit results

dineshraj9
Builder

I had the same issue and Splunk responded that SPL-96384 is open for the same -
http://answers.splunk.com/answers/242577/splunk-embedded-dashboard-failing-with-search-head.html

For now I suggest you create these dashboards(embedded ones) on a standalone server(which is not part of the cluster) and then use embed url generated from these servers.

Should get fixed in the latest version of Splunk.

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>