Reporting

Why have all of our Scheduled Reports stopped sending emails?

MwayneSmith
Explorer

Found this in the log:
"ERROR:root:(501, b'5.1.7 Bad sender address syntax', 'SplunkHost@sh-i-0c796565e382fd186') while sending mail"

Labels (1)
0 Karma
1 Solution

MwayneSmith
Explorer

In settings we had the "Send emails as" set to "XXXXX YYYYY" with a space. This worked fine for the past 18 months until our Splunk instance was upgraded including Python. Our emails began failing. Modified the "Send emails as" to "XXXXXYYYYY" without the space. Seems to be working again.

View solution in original post

0 Karma

MwayneSmith
Explorer

In settings we had the "Send emails as" set to "XXXXX YYYYY" with a space. This worked fine for the past 18 months until our Splunk instance was upgraded including Python. Our emails began failing. Modified the "Send emails as" to "XXXXXYYYYY" without the space. Seems to be working again.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

If the issue is not mentioned in the release notes, consider filing a bug report.

---
If this reply helps you, Karma would be appreciated.
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Check Settings->Server settings->Email settings. If you still have trouble, open a support request.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...