Is error in 'TsidxStats' only in Pivot for several data models related to JSON change?


Hello, I've starting working with data models and Pivot. They've been working for the most part, but recently, Pivot has been throwing errors for a few of the data models like this when I click on Pivot from the Data Model editor:

The search job has failed due to an error. You may be able view the job in the Job Inspector.
Error in 'TsidxStats': Could not find job directory for sid: 1681752470.124849_22F608DA-1DAB-4C64-BCA3-3D6EA29D58A4
The sid changes each time I run Pivot. I've found the tstats command in search.log, and if I run that as its own search outside of Pivot, sometimes it runs fine, sometimes it doesn't.
This seems to have corresponded with a recent change changing our events to JSON format. Could that be the issue? No reports, dashboards, or alerts seem to have been affected by that change. 
Thank you in advance!
Labels (2)
Tags (2)
0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Customer Survey!

If you use Splunk Observability Cloud, we invite you to share your valuable insights with us through a brief ...

.conf23 | Get Your Cybersecurity Defense Analyst Certification in Vegas

We’re excited to announce a new Splunk certification exam being released at .conf23! If you’re going to Las ...

Starting With Observability: OpenTelemetry Best Practices

Tech Talk Starting With Observability: OpenTelemetry Best Practices Tuesday, October 17, 2023   |  11AM PST / ...