Reporting

Btool multiline values don't have the '\' between lines that conf files have. How do I make them appear?

nwales
Path Finder

Running btool to create a combined config file from default and local doesn't give me a working config file because the line continuation marks are missing:

A search in the existing savedsearches.conf looks like:

search = source="/path/to/logfile.log" checkoutId (checkoutWithVas OR checkoutWithNoVas)\
| regex "checkoutId=[\w\d-]{32}" \
| rex "Domain: (?[\w\d.]+) Path:"\

While the output of btool looks like:

search = source="/path/to/logfile.log" checkoutId (checkoutWithVas OR checkoutWithNoVas)
| regex "checkoutId=[\w\d-]{32}" 
| rex "Domain: (?[\w\d.]+) Path:"

Any way to make them magically appear?

nwales
Path Finder

I tried that, worked this problem out when splunk complained about the config I had dumped to file.

0 Karma

woodcock
Esteemed Legend

Try dumping it to a file; it is possible that the terminal process is eating them when displaying to STDOUT.

0 Karma

Tune In & Win!

Don't miss out on your
chance to take home free
prizes by helping our players
save the Splunk Cloudom!

Dungeons & Data
Monsters: Splunk O11y
Day Editions Games
stream live:
5/4 at 6:30pm PST
5/5 at 7:00pm PST
on