Reporting

After upgrading from Splunk 6.3.3 to 6.4.0, why is the "Usage Report" link now missing from the "Licensing" page?

New Member

I'm running Splunk Free on Linux, not sure if this is the right forum for help on that...so apologies in advance if not.

I recently upgraded from 6.3.3 (I believe) to 6.4...I've done an upgrade prior to this with no issue. The only problem I'm having is that the link to the "Usage Report" is missing from the "Licensing" page. This is what the page used to look like : docs.splunk.com/images/e/e5/ChangeLicenseGroup60.png

However, now that button for "Usage Report" is gone. I can confirm that the data is still there if I navigate directly to splunk-host:8000/en-US/manager/search/licenseusage, and if I click on the breadcrumb to go back to "Licensing", I get back to the same page with the missing button.

None of the other questions about "license usage missing" deal with a missing link but missing data, so I am not sure if anyone else has reported the issue.

I've also re-saved my license choice and restarted the Splunk server.

Anyone have any suggestions on how to restore the link?

0 Karma

New Member

Follow-up...after upgrading to the latest release (6.5.0), the usage button has returned.

0 Karma

Path Finder

I just upgraded to 6.4.1 and have the same thing going on. I can get to the report by either changing the URL (as you did) or using the link in S.O.S. (which is just a link to the same URL). My Linux system is up to date and I have just updated Splunk in the last few hours. Also using the Splunk Free license.

0 Karma

Path Finder

i am also having same issue after upgrading our search head cluster environment from 6.3.3 to 6.4.1. the link

"https://splunk.company.com:8000/en-US/manager/system/licensing" is getting error with Page not found.

are you able to solve this ?

0 Karma

Splunk Employee
Splunk Employee

Can you find it through Distributed Management Console > Indexing > License Usage?

0 Karma

Builder

I'm running Splunk Free on Linux, not sure if this is the right forum for help on that...so apologies in advance if not.

This is most definitely the place for this question.

I looked on my license master and that button is still there for me after upgrading to 6.4.

0 Karma

New Member

I don't know... but I'm getting real tired of this getting moved around... and now straight out hidden. If they are so concerned about us going over our allocations that they shut us down... then maybe... just MAYBE this should actually be the landing page for the whole system?

0 Karma

Path Finder

Anyone ever figure this out?

0 Karma

Ultra Champion

We upgraded last night from 6.3.2 to 6.4.1 and the link is just fine.

0 Karma

New Member

Tried reinstalling Splunk, updating the server (Ubuntu 14.04 Server running on a VM). Also updated to Splunk 6.4.1. No luck at all.

Anyone have any suggestions on how to fix this? My server is fairly stock and dedicated only for Splunk. Not sure what else to do than to try to export the existing log data somehow and rebuild the server from scratch...or, just deal with the hassle of a missing button.

0 Karma

Splunk Employee
Splunk Employee

Mysterious. I can't reproduce the problem using the trial or free license in 6.4.0 or 6.4.1. The button is there for me. I will make some inquiries to see if anyone has suggestions.

0 Karma

New Member

6.4.1 here. Definately gone from two new clean installations.

0 Karma
Don’t Miss Global Splunk
User Groups Week!

Free LIVE events worldwide 2/8-2/12
Connect, learn, and collect rad prizes
and swag!