Monitoring Splunk

export serverclass hostname

Praz_123
Communicator

How can I export the host values in excel for the particular serverclass 

Is there is any query for that that will be helpful .

Path will be 

Deployment server -> forwarder management ->serverclass -> action (edit clients) -> need to export the hostname from the list 

0 Karma

livehybrid
SplunkTrust
SplunkTrust

Hi @Praz_123 

Try the following SPL query, which you can then export / save the results of.

| tstats count where index=_dsappevent data.serverClassName=100_IngestAction_AutoGenerated data.action=Install by data.clientId, data.serverClassName
| rename data.* as * 
| table serverClassName clientId 
| append 
    [ tstats count where index=_dsclient by 
        data.build data.clientId data.connectionId data.dns data.guid data.hostname data.instanceId 
        data.instanceName data.ip data.mgmt data.name data.package data.packageType data.splunkVersion data.utsname datetime 
    | dedup data.clientId sortby -datetime 
    | rename data.* as *]
    
| stats values(*) AS * by clientId
| table serverClassName clientId hostname

Replace "100_IngestAction_AutoGenerated" with your chosen serverclass,

 

Please let me know how you get on and consider accepting this answer or adding karma this answer if it has helped.
Regards

Will

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...