Monitoring Splunk

Remove the Splunk monitors from CLI

godman
Path Finder

I am trying to remove some monitors and when i tried from CLI it's throwing me Error : Parameters must be in the form '-parameter value'
command used : ./splunk remove monitor /app/abcded -auth '$USERNAME:$PASSWORD'

Tags (2)
0 Karma
1 Solution

godman
Path Finder

I found the solution, by adding the -index to the command it worked :

{noformat}
./splunk remove monitor -source -index

{noformat}

View solution in original post

0 Karma

godman
Path Finder

I found the solution, by adding the -index to the command it worked :

{noformat}
./splunk remove monitor -source -index

{noformat}

View solution in original post

0 Karma

mstjohn_splunk
Splunk Employee
Splunk Employee

Hi @godman , Did one of the answers below help ya? If yes, please click “Accept” below the best answer to resolve this post and upvote anything that was helpful. If no, please leave a comment with more feedback. Thanks.

0 Karma

mayurr98
SplunkTrust
SplunkTrust

Hello

Have a look at this remove monitor syntax given in this doc
https://docs.splunk.com/Documentation/Splunk/7.1.2/Data/MonitorfilesanddirectoriesusingtheCLI#CLI_co...

Try this

./splunk remove monitor -source <source>

let me know if this helps!

0 Karma

godman
Path Finder

Tried adding with the -source in the CLI and unfortunately same Error.

0 Karma

mayurr98
SplunkTrust
SplunkTrust

have a look at this
https://answers.splunk.com/answers/242495/what-is-parameters-must-be-in-the-form-parameter-v.html
dont put -auth '$USERNAME:$PASSWORD' and try

0 Karma

deepashri_123
Motivator

Hey@godman,

Can you try this syntax:
./splunk remove monitor -source

Let me know if this helps!!!

0 Karma

MuS
SplunkTrust
SplunkTrust

Did you try with '/app/abcded' ?

cheers, MuS

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.