Installation downloads SSL certificate signing behaviour


hi all -

it seems sometime in the last few weeks, splunk has moved to cloudfront to host their downloads.

unfortunately, the download link i get from the downloads page i'm using is getting redirected (i think) and generating SSL warnings because the cert (for * does not match the destination ( this raises a concern when we build our deployment scripts for new forwarders, as i've had to remove certificate checking to get my scripts to work.

any insight? maybe i'm just using the wrong wget / curl URL, and the HTTP redirect comes from an unexpected source?

 # wget -O splunkforwarder-6.2.2-255606-linux-2.6-x86_64.rpm ''
--2015-03-11 06:03:25--
Resolving,,, ...
Connecting to||:443. connected.
ERROR: no certificate subject alternative name matches
    requested host name “”.
To connect to insecurely, use ‘--no-check-certificate’.

curl -O ""
curl: (51) SSL: certificate subject name '*' does not match target host name ''
0 Karma


building on the response from here, elsewhere in answers, we can hardcode the URLs via HTTPS, which are served by a proper Splunk SSL cert:<version>/splunk/<version>/universalforwarder/ 

so in the end, i use this bit of code in my build script to get both the hash and the download file securely:

cd `mktemp -d`
wget "$VERSION/splunk/linux/$BUILD.$PTYPE" -O $BUILD.$PTYPE
wget "$VERSION/splunk/linux/$BUILD.$PTYPE.sha512" -O $BUILD.$PTYPE.sha512
sha512sum -c $BUILD.$PTYPE.sha512

which outputs:

splunk-6.2.1-245427-linux-2.6-amd64.deb: OK

note that i had to upgrade my OS to get a fresher copy of openssl, although it might've been my outdated wget install too, as mentioned here.

Splunk Employee
Splunk Employee

The wget command that I got from the download page is an http connection, not https, and it works as expected.

green@fat ~ $  wget -O splunkforwarder-6.2.2-255606-linux-2.6-x86_64.rpm ''
--2015-03-11 10:17:22--
Resolving,,, ...
Connecting to||:80. connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: [following]
--2015-03-11 10:17:23--
Resolving,,, ...
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13912657 (13M) [application/x-rpm]
Saving to: `splunkforwarder-6.2.2-255606-linux-2.6-x86_64.rpm'

100%[=====================================================================================================================================>] 13,912,657  8.23M/s   in 1.6s    

2015-03-11 10:17:25 (8.23 MB/s) - `splunkforwarder-6.2.2-255606-linux-2.6-x86_64.rpm' saved [13912657/13912657]`

If you are concerned about the validity of the package you can also wget the md5 or sha512 has by appending the appropriate extension to the end of the file name


apologies @matt but given a recent re-think with a colleague, i'll have to unmark the answer.

we are in fact concerned with the validity of the package contents. downloading either the package or the hash, or both via HTTP starts to defeat the purpose.

i think the easy answer / request is to ask Splunk to force SSL-enabled downloads for both the packages and the downloads page that serves the hashes, and to sign them with a certificate that matches the download URL.

i think it's becoming a de facto standard these days, so shouldn't be an unreasonable one. i've posted a similar response below that uses SSL and checks the hash.

0 Karma


yea i dont know why i had https in there.. i may have just done "copy link URL" instead of the wget command.

i don't like how you have to "download" the actual package just to see the wget URL.. so i tried to avoid clicking it i guess.

0 Karma


PS - why can't splunk just host repos for debian and redhat package types? would make life much easier for sure.

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!


Or Learn More in Our Blog >>