Upgrade of OpenSSL due to MitM potential


I have received a vulnerability report indicating a MitM exploit was successful against ports 8000, 8089 and 9997 on our Splunk servers and some (probably all) forwarders. The resolution is to update to 1.0.2h (or 1.0.1t, which doesn't apply) or higher. Please let me know if I need to provide more detail for Splunk to upgrade the version of openssl to close this vulnerability.

More details:
It was possible to obtain sensitive information from the remote host with TLS-enabled services.


The remote host is affected by a man-in-the-middle (MitM) information disclosure vulnerability due to an error in the implementation of ciphersuites that use AES in CBC mode with HMAC-SHA1 or HMAC-SHA256.
The implementation is specially written to use the AES acceleration available in x86/amd64 processors (AES-NI). The error messages returned by the server allow a man-in-the-middle attacker to conduct a padding oracle attack, resulting in the ability to decrypt network traffic.

UPgrade OpenSSL to 1.01.x or higher

Upgrade to OpenSSL version 1.0.1t / 1.0.2h or later.

Labels (1)
0 Karma

Community Manager
Community Manager

Hi @rkilen

Another user asked a question earlier this week about this. Thanks for providing more details for the Splunk community to be aware of.

0 Karma
.conf21 Now Fully Virtual!
Register for FREE Today!

We've made .conf21 totally virtual and totally FREE! Our completely online experience will run from 10/19 through 10/20 with some additional events, too!