Installation

Upgrade from 4.1 to 4.2.1

Path Finder

Tried to run the upgrade, and am receiving the following error. Is this a problem with the UI directory? I also checked the /opt/splunk/etc/system/local/indexes.conf and it appears to be correct. What file am I missing that I need to add the index path to? Thoughts?

Could not find new UI modules directory to install

An error occurred: Failed to run splunkd rest:
stdout:
--
stderr:Initializing applications: /opt/splunk/etc/apps
Found application directory: /opt/splunk/etc/apps/legacy
Found application directory: /opt/splunk/etc/apps/sample_app
Found application directory: /opt/splunk/etc/apps/pdfserver
Found application directory: /opt/splunk/etc/apps/EQALIS_Advisor
Found application directory: /opt/splunk/etc/apps/gettingstarted
Found application directory: /opt/splunk/etc/apps/learned
Found application directory: /opt/splunk/etc/apps/SplunkforF5
Found application directory: /opt/splunk/etc/apps/SplunkDeploymentMonitor
Found application directory: /opt/splunk/etc/apps/windows
Found application directory: /opt/splunk/etc/apps/afterglow
Found application directory: /opt/splunk/etc/apps/search
Found application directory: /opt/splunk/etc/apps/SplunkForwarder
Found application directory: /opt/splunk/etc/apps/SplunkLightForwarder
Found application directory: /opt/splunk/etc/apps/user-prefs
Found application directory: /opt/splunk/etc/apps/splunk_license_usage
Found application directory: /opt/splunk/etc/apps/unix
Found application directory: /opt/splunk/etc/apps/launcher
Found application directory: /opt/splunk/etc/apps/EQALIS_Network
Initialized at least 18 applications: /opt/splunk/etc/apps
terminate called after throwing an instance of 'PluginException'
  what():  Index configuration error: 'homePath' tag required in config for index os

Thanks

Tags (2)
1 Solution

Splunk Employee
Splunk Employee

according to the error, you don't have 'homePath' set for the index called os. Is this index disabled or enabled? If you've disabled it, but don't have 'homePath' set, then Splunk is going to complain about it and you should simply comment out everything about the index. If it is enabled, but isn't set, then it needs to be set. If it is enabled and looks to be set, something else could be happening, and I would run btool as follows:

$SPLUNK_HOME/bin/splunk cmd btool indexes list --debug

You could probably gather a good bit of information by following the instructions on another Splunk Answers post about something similar:

http://splunk-base.splunk.com/answers/6943/my-splunk-upgrade-is-failing-with-error-homepath-could-no...

View solution in original post

Splunk Employee
Splunk Employee

according to the error, you don't have 'homePath' set for the index called os. Is this index disabled or enabled? If you've disabled it, but don't have 'homePath' set, then Splunk is going to complain about it and you should simply comment out everything about the index. If it is enabled, but isn't set, then it needs to be set. If it is enabled and looks to be set, something else could be happening, and I would run btool as follows:

$SPLUNK_HOME/bin/splunk cmd btool indexes list --debug

You could probably gather a good bit of information by following the instructions on another Splunk Answers post about something similar:

http://splunk-base.splunk.com/answers/6943/my-splunk-upgrade-is-failing-with-error-homepath-could-no...

View solution in original post

Path Finder

Thank you so much, the problem was in the /opt/splunk/etc/apps/unix/local/indexes.conf file. The index should have been disabled. Commenting out the index, everything appears to have run perfectly.
Thanks again