Installation

UF Upgrade to 9.0.1 - disable kvstore?

Branden
Builder

Hello. We are trying to upgrade our Splunk UFs from 8.1.9 to 9.0.1. We use a configuration management tool (Puppet) to upgrade our UFs. This has worked fine until the leap to 9.0.1.

We are experiencing a timeout during a kvstore migration. This appears to be a known issue, and I employed the solution found here

The solution (or workaround) appears simple: Edit server.conf and add this:

[kvstore]
disabled = true

And that works.

However, I'm concerned about the consequences of this fix. I'm not familiar with the kvstore or how it works, etc. Is there any harm in using this workaround? 

Thank you in advance.

Labels (2)
0 Karma

isoutamo
SplunkTrust
SplunkTrust

Hi

kvstore is used only on SH layers, so there is no harm to disable it on all other nodes. Actually this is the best practices! 
r. Ismo

Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

 (view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...