Installation

Moved to search head cluster but I receive error: "Please make sure that the pass4SymmKey setting in server.conf, under [general], is the same for the License Master and all its slaves"

Contributor

Keep getting this error after moving to SH cluster,

Please make sure that the pass4SymmKey setting in server.conf, under [general], is the same for the License Master and all its slaves from ip='1.1.1.1' first failure time=1477268328 (Sun Oct 23 20:18:48 2016)

the key is the same for all of the servers, what else would cause this?

Labels (1)
1 Solution

Super Champion

Are you aware of this Known Issue regarding the key in 6.4.4?
2014-07-29 SPL-87816 When implementing an indexer cluster or search head cluster, you cannot set pass4SymmKey in the general stanza. The system default values in the clustering and shclustering stanzas override any user-provided values in the general stanza.
Workaround: Set the value in the [clustering] or [shclustering] stanza, depending on the type of cluster you're implementing.

View solution in original post

Super Champion

Are you aware of this Known Issue regarding the key in 6.4.4?
2014-07-29 SPL-87816 When implementing an indexer cluster or search head cluster, you cannot set pass4SymmKey in the general stanza. The system default values in the clustering and shclustering stanzas override any user-provided values in the general stanza.
Workaround: Set the value in the [clustering] or [shclustering] stanza, depending on the type of cluster you're implementing.

View solution in original post

Super Champion

Did this work? If not I can remove the answer so other folks will look at it.

0 Karma

Contributor

sorry for the long delay. this worked after we added the pass4SymmKey attribute

0 Karma

Communicator

Nice then just add the pass4SymmKey attribute to your [shclustering] stanza and/or to your [clustering] stanza and it should be fine.

0 Karma

Communicator

Hi,

try to put in the pass4SymmKey in cleartext to all Splunk instances again. (SH,CM,IDX,LicenseMaster) and restart splunkd. There must be a discrepancy.

What Versions are your Splunk Instances running?

kind regards

0 Karma

Contributor

6.4.4, we did this and we are still getting the error.

0 Karma