Installation
Highlighted

Installation/Update of Splunk 7.2.4 on SLES 12 failes due to dependency

Motivator

Hi all,

We are trying to upgrade our Splunk installation after migrating the OS from SLES 11 to SLES 12 SP3. Current version is 7.2.1, desired version is 7.2.4

The installation failed with the error "Failed dependencies: shadow-utils is needed by splunk-7.2.4-8a94541dcfac.x86_64"

However, the features of shadow-utils are included in the shadow package in SLES 12, as Splunk is using the useradd and groupadd commands from there. Furthermore, there is no official shadow-utils package for SLES12.

We are aware of the -nodeps feature of the RPM installer, but this is not an option, as this would need to rewrite all deployment scripts to still be able to install the RPM with limited priviledges only.

Anyone else came across this and has a feasible solution? We are planning to open a ticket with Splunk anyway, but I am still hoping for the community power 🙂

Thanks!

Highlighted

Re: Installation/Update of Splunk 7.2.4 on SLES 12 failes due to dependency

Motivator

We have opened a support case with Splunk and got the answer that this in fact might be a packaging problem on their side. Splunk is trying to resolve the issue.

For anyone else facing the same problem - refer to case #1279359

View solution in original post

0 Karma
Highlighted

Re: Installation/Update of Splunk 7.2.4 on SLES 12 failes due to dependency

New Member

Any news on this?

0 Karma
Highlighted

Re: Installation/Update of Splunk 7.2.4 on SLES 12 failes due to dependency

Motivator

Yes, according to Splunk there will be a fix in version 7.2.6 - until then they recommend to use the workaround by installing with the -nodeps option

0 Karma
Highlighted

Re: Installation/Update of Splunk 7.2.4 on SLES 12 failes due to dependency

Splunk Employee
Splunk Employee

An official fix is not yet available (so fix is not within 7.2.6). Please stick to the workaround provided so far, thanks.

0 Karma