Installation

App Browser: certificate verify failed

SplunkHead10
Explorer

Hi Community,

after installing Splunk everything seemed to work.
But after searching for Splunk Apps i get the following error in the app browser:
errror connecting: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed - please check the output of the `openssl verify` command for the certificates involved; note that if certificate verification is enabled (requireClientCert or sslVerifyServerCert set to "true"), the CA certificate and the server certificate should not have the same Common Name.. 

So I understand that there is a certificate error but I am not sure how to solve it. 

Thanks in advance

 

Labels (2)
Tags (3)
0 Karma
1 Solution

SplunkHead10
Explorer

I was able to solve the problem by editing the server.conf file under \Splunk\etc\system\default

[applicationsManagement]
sslVerifyServerCert = false

 

View solution in original post

SplunkHead10
Explorer

I was able to solve the problem by editing the server.conf file under \Splunk\etc\system\default

[applicationsManagement]
sslVerifyServerCert = false

 

View solution in original post

splunkyj
Path Finder

@SplunkHead10 it might be a better idea to revert your changes from the default folder, and apply it to the local folder instead. If you have to update or restore default, your local settings will not be affected. I could be wrong, I'm still fairly new.