Getting Data In

Using Python SDK to run search against data model -- permissions issues

himynamesdave
Contributor

All I'm running a query using python SDK against a data model stored in a custom app. I get the response:

FATAL: Error in 'TsidxStats': Could not find datamodel: MYDATAMODEL

I know this error is caused because the DM is set to App level permissions. It appears the search via the SDK is being dispatched from a default location (maybe search app?).

Can someone let me know if it's possible to explicitly set the dispatch app when running requests through the SDK?

micahkemp
Champion

You need to include your app path in the URL. In curl it might look like:

curl -k -u admin https://localhost:8089/servicesNS/<your user>/<your app>/search/jobs/ -d search="| tstats count FROM datamodel=<your datamodel>"

Where <your app> is the app path as shown in the URL bar of your browser while using that app.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Note: This post outlines a proposed architecture and serves as an interest check. If we secure commitments ...