Getting Data In

Universal ForwarderのCPU使用率を下げる方法について

cweiliou_splunk
Splunk Employee
Splunk Employee

WindowsサーバにインストールされたUniversal Forwarder ( UF ) が時々20%くらいまでCPUを使用してしまいます。
常に20%ではなく、急に20%まで上昇し、そして、何分後にまた3, 4%まで下がりますが、同じサーバにインストールされている他のアプリケーションはすでにかなりのCPUを使用していますので、できるだけUFのCPU使用率を下げたいですが、何かいい方法がありますでしょうか。

0 Karma
1 Solution

cweiliou_splunk
Splunk Employee
Splunk Employee

使用していない、Windows 関連のスタンザを明示的に inputs.conf から無効にしてみてください。
例えば、[WinPrintMon://printer] を使用していない場合、"disabled = 1" および "interval = -1" を追加して、無効にしてみてください。

[WinPrintMon://printer]
interval = -1
disabled = 1

注意点としては、Modular inputsは"disabled =1"だけでは完全に無効化できないので、完全に無効化したい場合は"interval = -1"も追加してください。

View solution in original post

0 Karma

cweiliou_splunk
Splunk Employee
Splunk Employee

使用していない、Windows 関連のスタンザを明示的に inputs.conf から無効にしてみてください。
例えば、[WinPrintMon://printer] を使用していない場合、"disabled = 1" および "interval = -1" を追加して、無効にしてみてください。

[WinPrintMon://printer]
interval = -1
disabled = 1

注意点としては、Modular inputsは"disabled =1"だけでは完全に無効化できないので、完全に無効化したい場合は"interval = -1"も追加してください。

View solution in original post

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!