Getting Data In

Is there a way to change the token prefix from splunk to bearer?

nareshkumarg
Path Finder

Hi All,

We are trying to push data from Grafana to Splunk using HEC based integration. When we did the testing we found that the header sent by Grafana was in the following format "Bearer <HEC TOKEN>" instead of "splunk <HEC TOKEN>" format.

Because of this, authentication failed and we cannot ingest data into Splunk. We manually tried the same via postman where we have an option to change the Bearer prefix and it worked. Our ask is, do we have a method to change the Header Authorization from Splunk to Bearer to fix the authentication issue?

Please help.

Regards,

Naresh

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust
You might need to ask on a Grafana forum or contact them for support.
---
If this reply helps you, an upvote would be appreciated.
0 Karma

nareshkumarg
Path Finder
0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>