Getting Data In
Highlighted

I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

Explorer

I'm running 6.3.2 and when I did the initial setup for my receiver, I misunderstood the directions I was getting and mistakenly set the Receiver to also be a forwarder and a Receiver of itself. So I now have another Forwarder listed on my Deployment page and I would like to remove it without uninstalling and reinstalling the Receiver. It doesn't appear to be harming anything, just more of an eyesore to look at my deployment and have one server always listed as missing.

0 Karma
Highlighted

Re: I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

SplunkTrust
SplunkTrust

Go to Settings-> Forwarding and receiving -> Forward data and remove any entry that you find. Do this for all receivers.

0 Karma
Highlighted

Re: I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

Splunk Employee
Splunk Employee

remove the forwarding option, from the UI settings > forwarding and receiving > forwarding , or from the tcpout config in outputs.conf

Highlighted

Re: I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

Explorer

I checked both the forwarding page and the outputs.conf file and didn't see anything about the receiving machine as a forwarder. Any other setting that might cause this to happen?

0 Karma
Highlighted

Re: I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

SplunkTrust
SplunkTrust

The file name is outputs.conf and the stanza name will be [tcpout... ].

0 Karma
Highlighted

Re: I set my receiver to also forward data to itself by mistake. How do I remove the forwarder instance without uninstalling the receiver?

Explorer

That's my bad there I checked the correct file, outputs.conf, I just typed the wrong thing in my comment, I'll edit the comment.

0 Karma