Getting Data In

How does the JOIN or single TRANSACTION work in same log file having multiple source types when we don't have a unique key or referential key?

Aakanksha
Path Finder

Pleas Check Sample Data and Query

link text

Tags (1)
0 Karma
1 Solution

yannK
Splunk Employee
Splunk Employee

JOIN and TRANSACTION both require at least one field to correlate events.

  • About the same log file : The JOIN uses a sub search so it could use the same results than the main search.
  • is the excel example the actual log file ?

View solution in original post

0 Karma

yannK
Splunk Employee
Splunk Employee

JOIN and TRANSACTION both require at least one field to correlate events.

  • About the same log file : The JOIN uses a sub search so it could use the same results than the main search.
  • is the excel example the actual log file ?
0 Karma

Aakanksha
Path Finder

For calculations, we used the below approach:

((A/((SUM(A,B,H)-SUM(D,C,G,E,F)))100))

In Splunk:

sourcetype=source1 | join date,time [search sourcetype=source3] | eval add1 = A +B+ H|join date,time [search sourcetype=source2] | eval add2=C+D |join date,time [search sourcetype=source3] |eval add3 =G+E|eval add4 = F+add3|eval sub = add1 - add4 |eval div = A/sub |eval final-result = div*100

By using “join” function here, we were able to get column names of all three source types and use eval on them. But the join does not consider all the possible combinations.
SHEET contains sample data.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...