Getting Data In

Heavy Forwarder outputs.conf settings not working as expected

dbturner18
Loves-to-Learn Lots

Greetings,

I am having issues with my heavy forwarder getting data into my indexers without having a local indexes.conf containing the index name.

I am doing all .conf work from the cli and not the webUI.   The issue is the "forwardedindex.filter.disbale=true" is not working as expected and I have to either:

1.  Create a local copy of the index I want to send to in indexes.conf

2. Add the index name to the whitelist setting for outputs.conf

Otherwise data does not get sent to the indexers.

Assistance please.

Here is my output.conf for example:

[tcpout]
defaultGroup = test_indexers
forwardedindex.filter.disable = true
indexAndForward = false


[tcpout:test_indexers]
#server = <ip address>:<9996>
server = x.x.x.x:9996,x.x.x.x:9996
disabled = false
sslPassword = <nope>
sslCertPath = $SPLUNK_HOME
sslRootCAPath = $SPLUNK_HOME

Labels (2)
0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Unified Identity - Now Available for Existing Splunk ...

Raise your hand if you’ve already forgotten your username or password when logging into an account. (We can’t ...

Index This | How many sides does a circle have?

February 2024 Edition Hayyy Splunk Education Enthusiasts and the Eternally Curious!  We’re back with another ...

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...