Getting Data In

Eventgen - Ensure current timestamp

ehqtrainorm
Explorer

Hi All,


I have a few existing inputs with EventGen (v6.5.2) and they work perfectly on Splunk 8.0.5.

The use case I am having trouble with is where:

a) The timestamp is not contained in the _raw data (the actual Production input uses the current index time)

b) There are other timestamps in _raw (they are not related to _time, are separate fields).

c) All events in the csv sample file must be ingested each interval.

 

I have tried both sample mode and replay mode.

Sample mode ingests the data but identifies different date/time values in _raw and uses that as _time, which is unexpected. This is even while autotimestamp = false.

ehqtrainorm_0-1598568180744.png

 

In replay mode, nothing is ingested due to errors where it can't find the timeField (there is a time column in the csv that I referenced).

 

So how can I ingest all events in the sample csv file while ensuring _time is the current time, and not dependent on any timestamps in the _raw?

 

Here is my config for mode = sample.

 

[ops_724events_ggprocdetail_sample]
disabled = false
mode = sample
interval = 60
sampletype = csv
autotimestamp=false

earliest = -1m
latest = now

 

Csv sample file has the following columns:

time,index,host,source,sourcetype,"_raw"

0 Karma
Get Updates on the Splunk Community!

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...