Getting Data In

DB Connect: How to prevent append command from sorting columns in alphabetical order in the result set?

pramit46
Contributor

I have a query that looks like the following:
index=<> host=<> |rex=<> spath <>|table a,k,h|sort time|append[|dbquery DB "select X,Z,W,P from table_T where <> Order By time_col"]

the result set has the following columns:
a|k|h|P|W|X|Z
While I expect
a|k|h|X|Z|W|P

How can I get rid of this automatic alphabetical sorting?
While I run the dbquery alone, it works fine and shows me the expected columns.

1 Solution

russellliss
Path Finder

I have gotten around this before by using the table command, so in your example :

index= host= |rex= spath |table a,k,h|sort time|append[|dbquery DB "select X,Z,W,P from table_T where  Order By time_col"] | table a,k,h,X,Z,W,P

View solution in original post

russellliss
Path Finder

I have gotten around this before by using the table command, so in your example :

index= host= |rex= spath |table a,k,h|sort time|append[|dbquery DB "select X,Z,W,P from table_T where  Order By time_col"] | table a,k,h,X,Z,W,P

pramit46
Contributor

Thanks a lot @russellliss. This was really helpful

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...