Getting Data In

Class question

stromingj
New Member

Run a search in the metrics index over the last 15 minutes. Use the stats command to find the middle number, the average and the most frequent occurrence of the field called "UsedBytes". Use an 'as' clause to rename all your fields. Split by users. Add column totals, customize your totals label, and place it underneath the user column. Finally, ONLY evaluate UseBytes that are MORE THAN the value of 0. 

 

My string didnt work  (index=metrics | stats mode(UsedBytes), avg(UsedBytes), median(UsedBytes) as Bytes

I am new to Splunk and need some assitance. 

Labels (1)
0 Karma

to4kawa
Ultra Champion

I'm sorry.

0 Karma

to4kawa
Ultra Champion

| tstats mode(UsedBytes), avg(UsedBytes), median(UsedBytes) as Bytes sum(UsedBytes) as totals where index=metrics by user

stromingj
New Member

Doesnt run.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...